I summarised a list of FAQ about the memory request and limit in Kubernetes. Also I have a real example down the bottom. 1) What if Container exceed memory request? Totally fine, a Container can exceed its memory request if the Node has memory available. 2) What if Container exceed memory limit? Thats dangerous, as … Continue reading The myth of memory requests and limits in Kubernetes
CloudFront Edge Cache Settings
Caching is 'fun' if you don't set it up correctly. A useful cheat sheet of CloudFront edge cache TTL settings that I found in AWS documents site. Origin Configuration Minimum TTL = 0 Seconds Minimum TTL > 0 Seconds The origin adds a Cache-Control max-age directive to objects CloudFront caching CloudFront caches objects for the lesser of … Continue reading CloudFront Edge Cache Settings
Pods are not recreated after kubernetes node failure
We had a short outage recently which was caused by the pods were not recreated on other nodes when the previous node become unresponsive. It is Kubernetes 1.6, and according to the documentation, it is expected in some cases. "If the Status of the Ready condition is “Unknown” or “False” for longer than the … Continue reading Pods are not recreated after kubernetes node failure
SP-initiated vs IDP-initiated SSO
A nice diagram that I found on Okta illustrates the workflow of both SP-initiated and IDP-initialed SSO. Reference: https://developer.okta.com/standards/SAML/index http://docs.oasis-open.org/security/saml/v2.0/saml-core-2.0-os.pdf
Service Catalog in OpenShift
OpenShift 3.7 is now able to create and use some AWS services via the Service Catalog. Here is a quick demo that I found out on YouTube: https://www.youtube.com/watch?time_continue=5&v=vqHNwJVDNlQ The technology behind it is called 'Open Service Broker API'. I am not sure for now if supports multi AWS accounts, it would be nice if it … Continue reading Service Catalog in OpenShift


