Error rendering ‘com.atlassian.jira.jira-view-issue-plugin:activitymodule’. Please contact your Jira administrators.


If you are seeing the above error in the Activity section of a Jira issue. Your Jira may have hit a Jira bug. Check this out – https://jira.atlassian.com/browse/JSDSERVER-5966

To confirm it, you can try:

(1) Check the issue via API – https://<jira-server>/rest/api/2/issue/issue-key

(2) Search comment in the result, to see what you got there. In our case, due to a human error, an issue was half-way updated via Email. (The Email gets deleted before Jira completed the work). So there is a error message in the comment.

(3) The above scenario triggers the bug, as there is no Author for that comment. To confirm it, you can query the database: SELECT * FROM JIRAACTION WHERE id = <comment id>;

As you can see the Author column is [NULL].

(4) As a workaround, you can add an Author for that comment by running the SQL. e.g. update jiraaction set author=jackie.chen where id = 1722600;

4 thoughts on “Error rendering ‘com.atlassian.jira.jira-view-issue-plugin:activitymodule’. Please contact your Jira administrators.

  1. Thanks for this, seems to be the only reference I can find to this issue. Just started for us today. However, when I run the API I get
    {“errorMessages”:[“Issue Does Not Exist”],”errors”:{}}

    Wondering if I am understanding the API to run properly. Other than changing out the server name, is the rest of the command just as you have it, i.e. just add /rest/api/2/issue/<issue-key&gt after server address?

    If so, perhaps our issue has a different root cause

  2. Thanks, that makes sense now. I see your original post indicated seeing the error message on a specific issue. We have seen that but also seem to have a larger issue.

    In case it helps anyone else, we actually have an issue where we cannot see the Activity on any issue – clicking on Activity tab in the Activity section generates a large list of errors. I did try researching a few issues created recently using the API and comment search as you mentioned, but did not see an issue. As it seems to affect all issues, it is tough to know which issue might be causing the problem, or if the problem is at an application level. I have created a support ticket with Atlassian on this to see if they can help determine the root cause.

    First few lines of Activity error displayed (when it does not display the red error box at the top of this post):
    An error occurred whilst rendering this message. Please contact the administrators, and inform them of this bug. Details: ——- org.apache.velocity.exception.MethodInvocationException: Invocation of method ‘renderActivityModule’ in class com.atlassian.jira.plugin.issuenav.IssueNavAction threw exception com.atlassian.templaterenderer.RenderingException: org.apache.velocity.exception.MethodInvocationException: Invocation of method ‘getHtml’ in class com.atlassian.streams.jira.portlet.ActivityStreamIssueTab$1 threw exception com.atlassian.gadgets.GadgetParsingException: org.apache.shindig.gadgets.GadgetException: Unable to retrieve gadget xml. HTTP error 500 at viewissue/activityblock.vm[line 73, column 31] at com.atlassian.jira.jira-issue-nav-plugin:webPanelaction//templates/ka-issuetab.vm[line 5, column 9] at org.apache.velocity.runtime.parser.node.ASTMethod.handleInvocationException(ASTMethod.java:337) at

    1. Not sure if you are encountering the same issue like we had. But most likely it was caused by that something are missing in the database. Due to that the page just could not be rendered.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s