We recently had an BitBucket incident - one project team found that they are unable to merge the pull request after approval, and the server always returns an error message: So we checked their project repository, and here is something that astonish us: The repository have a few hundreds of branches. The size is nearly … Continue reading BitBucket Server Unreachable When Merge Pull Request
ERR_CERT_COMMON_NAME_INVALID because of Subject Alternative Name missing
If you are seeing similar errors in Chrome as below, your private cert probably missed the SAN. Starting from Chrome 58, it validates the DNS against the SAN that is in the certificate. Here is the quote that I found "Certificates have two ways to express the domain/IP they're bound to - one which is … Continue reading ERR_CERT_COMMON_NAME_INVALID because of Subject Alternative Name missing
Escalator – auto-scaling tool for Kubernetes
Atlassian recently open sourced its in-house auto-scaling tool for Kubernetes - Escalator. I have not gotten a chance to try it yet, but according to this article, the tools is initially designed for the batch workloads which can not tolerate scaling-up delay. The idea behind it is to allow user to set up the percentage … Continue reading Escalator – auto-scaling tool for Kubernetes
Bamboo Builds Report
Want to get insights of your Bamboo builds? Here is a script that I wrote to generate the report in spreadsheet. This is how it looks like:
Use helm in Kubernetes
Helm is the package manager for Kubernetes, you can think it as yum/apt/homebrew. It contains two parts: Server (tiller) and Client (helm). helm client can be installed on Linux/Mac/Windows, the package can be found here. Helm manages the Kubernetes charts which are pre-configured Kubernetes resources. In the following example, I will show you how to … Continue reading Use helm in Kubernetes



